php

کشف آسیب پذیری خطرناک در جاوا و پی اچ پی!!

یک آسیب پذیری برطرف نشده در فریم ورک OpenAPI اجرای کدهای مخرب را بر روی رایانه های کاربران ممکن می کند.

به گزارش مشرق، ابزار هک Metasploit که به همین منظور طراحی شده استفاده از حفره امنیتی مذکور را ساده تر می کند. این حفره میلیون ها کاربر برنامه ها و خدماتی همچون جاوا، نود جی اس، روبی و پی اچ پی را دچار مشکل می کند.

از جمله شرکت های فناوری که محصولات و خدماتی بر همین دلیل ارائه می دهند می توان به مایکروسافت، پی پال، گتی ایمیج، Intuit و Apigee اشاره کرد.

OpenAPI که به Swagger APIs هم مشهور است، طراحی متن باز به منظور ارائه رابط کاربری استاندارد و رها از بخش بندی ها زبان های برنامه نویسی است. با استفاده از این رابط کاربری انسان ها و کامپیوتر ها توانایی به شناسایی و درک قابلیت های یک سرویس بدون دسترسی به کد منبع، اسناد یا ترافیک شبکه مرتبط با آن خواهند بود.

اسکات دیویس، محقق امنیتی شرکت Rapid7 می گوید افشای این آسیب پذیری نشان می دهد اجرای کدهای مخرب بر روی رایانه های مختلف و سواستفاده از NodeJS، PHP، Ruby و Java تا چه حد آسان است. وی هشدار می دهد که ممکن است این مشکل در برخی دیگر از زبان های برنامه نویسی نیز وجود داشته باشد. تحقیقات در این زمینه برای یافتن وصله امنیتی موثر همچنان ادامه دارد.